臆病者の一撃@

思いついたことを適度に

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。
凄い困ったのでメモとして残しておきます。対象製品はLogitecのLAN-W450AN/U2です。使用OSはWindows10。
経緯
・半年ぐらい前に2.4GHz、5GHz帯対応のLAN-W450AN/U2を買ったが5GHz帯は見つけたり見つけなかったりだった、iPhoneでも同様の症状だったため親機の5GHz帯の電波が弱いのかと思ってほっといた(たぶん合ってる)
・新しく無線LAN親機を購入したのでついに5GHz帯が使えるかと思ったが、5GHz帯を見つけてくれないのでもっかい1から入れなおそうとした
問題発生から解決まで(消えた半日)
デバイスマネージャーで一度LAN-W450AN/U2を無効にしてから有効にしたら正常に動作してくれなくなった
・ドライバを入れ直す→ダメ
・説明書通りにデバイスマネージャーからLAN-W450AN/U2を削除して、1からやり直す→ダメ
色々調べているとデバイスマネージャーからデバイスを削除してもレジストリに残っている部分があり、Logitec製品はそこも削除しないとうまくいってくれないらしい(Amazonのレビューから)ので色んな手を駆使して残ってるファイルを削除してこねくり回してたんですが直る見込みもなく、仕方ないのでシステムの復元で1週間前の状態に戻す
価格.comのレビューと、windows8(10)にアップグレードしたら無線LANが使えなくなったという多数の報告から、どうもLogitecがHPで出しているデバイスドライバではプログラムの問題によりwindows8.1以降だと5GHz帯を探せないらしいという事が発覚、しかし価格.comのリンク先が切れていてどうしようもない
・NECのAterm WL450NU-AGと同じチップを使用しているようで、そのドライバを使えばいいとのこと、でも疲れたので復元した後の状態で寝る
・起きてまた調べてたらMicroSoftのコミュニティに手がかりを発見、LAN-W450AN/U2は Ralink のRT3573というチップが使われているらしい、このレスについてるリンク先からは有益な情報が得られなかったがどうにかRalinkのRT3573の最新ドライバを探し出して(USBのRT357Xのやつ)、すでに入ってるドライバを削除→デバイスをデバイスマネージャから削除→一度シャットダウンしてから持ってきたドライバを入れ直して(ドライバだけ、制御ソフト?みたいなのは入れなかった)正常に動作するのを確認、デバイスマネージャーからプロパティ開いて詳細設定でChannel Modeを2.4GHz+5GHzから5GHzに変更し、元に戻したら5GHz帯も見つけられるようになりました。ちゃんちゃん
教訓
販売会社がドライバの更新を止めていても使われているチップを探してそれに対応したドライバをいれてばハッピー
Logitec製品はややいこしいのでやめましょう(ついでにBAFFALOもやめましょう)
スポンサーサイト

Author:ハモン
昔、メイプルストーリーというゲームにおいて、なつめサーバーではアビヌス、かりんサーバーではハモンという名前で遊んでいました。現在遊んでいるゲームでもこれらに準ずる名前を使用しています。
徒然なるままに、書きたいことを書いていきます。
リンクはフリーです。

FX
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。